El libre pensamiento para un internet libre

No estas registrado.  

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#26 25-08-2018 15:19:40

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

bala por favor usa el texto formateado que te explicado antes para poner lo que muestra la terminal



instala esto

sudo apt install ocl-icd-opencl-dev

y compila de nuevo.

Desconectado

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#27 25-08-2018 15:29:10

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

muchas gracias señor crash. Pasaste tu tiempo para ayudarme. Sé que eres una persona ocupada. continuaremos ... por favor

Desconectado

#28 25-08-2018 15:37:09

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

[email protected]:~/Pyrit/modules/cpyrit_opencl$ python setup.py build
The headers required to build the OpenCL-kernel were not found. Trying to continue anyway...
running build
running build_ext
Building modules...
building 'cpyrit._cpyrit_opencl' extension
x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-rHYsq1/python2.7-2.7.15=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I/usr/include/python2.7 -c _cpyrit_opencl.c -o build/temp.linux-x86_64-2.7/_cpyrit_opencl.o -Wall -fno-strict-aliasing -DVERSION="0.5.0"
In file included from /usr/include/CL/cl.h:36,
                 from _cpyrit_opencl.c:45:
/usr/include/CL/cl_version.h:34:9: note: #pragma message: cl_version.h: CL_TARGET_OPENCL_VERSION is not defined. Defaulting to 220 (OpenCL 2.2)
 #pragma message("cl_version.h: CL_TARGET_OPENCL_VERSION is not defined. Defaulting to 220 (OpenCL 2.2)")
         ^~~~~~~
_cpyrit_opencl.c: In function ‘ocldevice_compile’:
_cpyrit_opencl.c:367:9: warning: ‘clCreateCommandQueue’ is deprecated [-Wdeprecated-declarations]
         self->dev_queue = clCreateCommandQueue(self->dev_ctx, self->device, 0, &err);
         ^~~~
In file included from _cpyrit_opencl.c:45:
/usr/include/CL/cl.h:1741:1: note: declared here
 clCreateCommandQueue(cl_context                     /* context */,
 ^~~~~~~~~~~~~~~~~~~~
x86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-rHYsq1/python2.7-2.7.15=. -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-rHYsq1/python2.7-2.7.15=. -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-x86_64-2.7/_cpyrit_opencl.o -lcrypto -lz -lOpenCL -o build/lib.linux-x86_64-2.7/cpyrit/_cpyrit_opencl.so
[email protected]:~/Pyrit/modules/cpyrit_opencl$ sudo python ./setup.py install
The headers required to build the OpenCL-kernel were not found. Trying to continue anyway...
running install
running build
running build_ext
Building modules...
running install_lib
copying build/lib.linux-x86_64-2.7/cpyrit/_cpyrit_opencl.so -> /usr/local/lib/python2.7/dist-packages/cpyrit
running install_egg_info
Writing /usr/local/lib/python2.7/dist-packages/cpyrit_opencl-0.5.0.egg-info
[email protected]:~/Pyrit/modules/cpyrit_opencl$

[email protected]:~$ pyrit list_cores
Failed to load Pyrit's OpenCL-core ('Failed to enumerate OpenCL-platforms (Unknown CLresult)').
Pyrit 0.5.1 (C) 2008-2011 Lukas Lueg - 2015 John Mora
https://github.com/JPaulMora/Pyrit
This code is distributed under the GNU General Public License v3+

The following cores seem available...
#1:  'CPU-Core (SSE2/AES)'
#2:  'CPU-Core (SSE2/AES)'
#3:  'CPU-Core (SSE2/AES)'
#4:  'CPU-Core (SSE2/AES)'
#5:  'CPU-Core (SSE2/AES)'
#6:  'CPU-Core (SSE2/AES)'
#7:  'CPU-Core (SSE2/AES)'
#8:  'CPU-Core (SSE2/AES)'

Desconectado

#29 25-08-2018 15:45:25

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

ok, ahora modifica el archivo

/home/bala/.pyrit/config

limit_ncpus = -1
use_OpenCL = true

Desconectado

#30 25-08-2018 16:18:31

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

[email protected]:~$ /home/bala/.pyrit/config
bash: /home/bala/.pyrit/config: Permission denied
[email protected]:~$



[email protected]:~$ cat /home/bala/.pyrit/config
default_storage = file://
limit_ncpus = 0
rpc_announce = true
rpc_announce_broadcast = false
rpc_knownclients = 
rpc_server = false
use_CUDA = false
use_OpenCL = false
workunit_size = 75000

Desconectado

#31 26-08-2018 11:54:36

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

¿has cambiado en el archivo de configuración de pyrit false por true?
si no lo has hecho hazlo.   

use_OpenCL = false (cambialo)
                       
use_OpenCL = true

instala el controlador de la tarjeta gráfica amd.

Desconectado

#32 26-08-2018 14:13:30

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,476

Re: Linux tan difícil de instalar AMD GPU

Bala, debes usar la opción "texto formateado" cuando pones salidas de consola. He editado tus mensajes anteriores para que se vean como debido.

Desconectado

#33 26-08-2018 17:26:18

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

kali muy difícil instalación de controlador AMD.
pero muchas gracias. yo arreglo regresa

Desconectado

#34 26-08-2018 17:31:00

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

me puedes explicar cómo AMD GPU pro
instalación del controlador para kali linux ??? porque descargo el controlador de Linux pero ... el sistema operativo no es compatible

https://support.amd.com/en-us/kb-articl … Notes.aspx

Desconectado

#35 26-08-2018 18:22:56

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

tendrás que probar con este controlador .deb de ubuntu en kali-linux.
sigue las instrucciones de aquí.
https://support.amd.com/en-us/kb-articl … stall.aspx

Desconectado

#36 27-08-2018 00:08:09

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

[email protected]:~/amdgpu-pro-18.20-606296$ ./amdgpu-pro-install -y
Unsupported OS
[email protected]:~/amdgpu-pro-18.20-606296$

Creo que Kali tiene una forma diferente de instalar el controlador AMD. tal vez algún comando de actualización automática?

Ultima edición por bala (27-08-2018 04:56:46)

Desconectado

#37 28-08-2018 11:03:54

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

no se que extensión tiene el archivo que te has descargado. si no me pones toda la información no puedo ayudarte mas, porque yo uso nvidia.

Desconectado

#38 28-08-2018 16:02:59

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

amdgpu-pro-17.40.2712-510357

amdgpu-pro-18.20-606296

Ultima edición por bala (28-08-2018 16:03:35)

Desconectado

#39 28-08-2018 19:13:47

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

bala te complicas mucho la vida, si hicieras lo que te dicho, tienes todos los controladores aquí
https://www2.ati.com/drivers/linux/ubun … 261.tar.xz
descomprime el archivo tar e instala lo que necesites, y sigue los pasos que te pone en el enlace del mensaje mío anterior.

Desconectado

#40 29-08-2018 05:04:31

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

gracias, descargaré para verificar big_smile

Desconectado

#41 29-08-2018 12:47:42

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

[email protected]:~/amdgpu-pro-17.40-492261$ ./amdgpu-pro-install -y
bash: ./amdgpu-pro-install: Permission denied

(((( Permission denied )))) ????? Please

Desconectado

#42 29-08-2018 13:04:38

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

dale permisos de ejecución. (ese archivo es un script de bash.)

sudo chmod +x ./amdgpu-pro-install

Desconectado

#43 29-08-2018 15:04:14

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

[email protected]:~$ ls
amdgpu-pro-17.40-492261  HelloWorld        Pictures
bin                      HelloWorld.cl     Public
Desktop                  HelloWorld.cl.1   Pyrit
Documents                HelloWorld.cpp    Templates
Downloads                HelloWorld.cpp.1  Videos
etc                      Music
[email protected]:~$ cd amdgpu-pro-17.40-492261
[email protected]:~/amdgpu-pro-17.40-492261$ ls
amdgpu-pro_17.40-492261_amd64.deb
amdgpu-pro_17.40-492261_i386.deb
amdgpu-pro-core_17.40-492261_all.deb
amdgpu-pro-dkms_17.40-492261_all.deb
amdgpu-pro-install
amdgpu-pro-lib32_17.40-492261_amd64.deb
clinfo-amdgpu-pro_17.40-492261_amd64.deb
clinfo-amdgpu-pro_17.40-492261_i386.deb
gst-omx-amdgpu-pro_1.0.0.1-492261_amd64.deb
gst-omx-amdgpu-pro_1.0.0.1-492261_i386.deb
hsa-ext-amdgpu-pro-finalize_1.1.6-492261_amd64.deb
hsa-ext-amdgpu-pro-image_1.1.6-492261_amd64.deb
hsa-runtime-tools-amdgpu-pro_1.1.6-492261_amd64.deb
hsa-runtime-tools-amdgpu-pro-dev_1.1.6-492261_amd64.deb
ids-amdgpu-pro_1.0.0-492261_all.deb
libdrm2-amdgpu-pro_2.4.82-492261_amd64.deb
libdrm2-amdgpu-pro_2.4.82-492261_i386.deb
libdrm-amdgpu-pro-amdgpu1_2.4.82-492261_amd64.deb
libdrm-amdgpu-pro-amdgpu1_2.4.82-492261_i386.deb
libdrm-amdgpu-pro-dev_2.4.82-492261_amd64.deb
libdrm-amdgpu-pro-dev_2.4.82-492261_i386.deb
libdrm-amdgpu-pro-radeon1_2.4.82-492261_amd64.deb
libdrm-amdgpu-pro-radeon1_2.4.82-492261_i386.deb
libdrm-amdgpu-pro-utils_2.4.82-492261_amd64.deb
libdrm-amdgpu-pro-utils_2.4.82-492261_i386.deb
libegl1-amdgpu-pro_17.40-492261_amd64.deb
libegl1-amdgpu-pro_17.40-492261_i386.deb
libgbm1-amdgpu-pro_17.40-492261_amd64.deb
libgbm1-amdgpu-pro_17.40-492261_i386.deb
libgbm1-amdgpu-pro-base_17.40-492261_all.deb
libgbm1-amdgpu-pro-dev_17.40-492261_amd64.deb
libgbm1-amdgpu-pro-dev_17.40-492261_i386.deb
libgl1-amdgpu-pro-appprofiles_17.40-492261_all.deb
libgl1-amdgpu-pro-dri_17.40-492261_amd64.deb
libgl1-amdgpu-pro-dri_17.40-492261_i386.deb
libgl1-amdgpu-pro-ext_17.40-492261_amd64.deb
libgl1-amdgpu-pro-ext_17.40-492261_i386.deb
libgl1-amdgpu-pro-glx_17.40-492261_amd64.deb
libgl1-amdgpu-pro-glx_17.40-492261_i386.deb
libglamor-amdgpu-pro-dev_1.19.0-492261_amd64.deb
libglamor-amdgpu-pro-dev_1.19.0-492261_i386.deb
libgles2-amdgpu-pro_17.40-492261_amd64.deb
libgles2-amdgpu-pro_17.40-492261_i386.deb
libllvm5.0-amdgpu-pro_5.0-492261_amd64.deb
libllvm5.0-amdgpu-pro_5.0-492261_i386.deb
libopencl1-amdgpu-pro_17.40-492261_amd64.deb
libopencl1-amdgpu-pro_17.40-492261_i386.deb
libvdpau-amdgpu-pro_17.0.1-492261_amd64.deb
libvdpau-amdgpu-pro_17.0.1-492261_i386.deb
llvm-amdgpu-pro_5.0-492261_amd64.deb
llvm-amdgpu-pro_5.0-492261_i386.deb
llvm-amdgpu-pro-5.0_5.0-492261_amd64.deb
llvm-amdgpu-pro-5.0_5.0-492261_i386.deb
llvm-amdgpu-pro-5.0-dev_5.0-492261_amd64.deb
llvm-amdgpu-pro-5.0-dev_5.0-492261_i386.deb
llvm-amdgpu-pro-5.0-doc_5.0-492261_all.deb
llvm-amdgpu-pro-5.0-runtime_5.0-492261_amd64.deb
llvm-amdgpu-pro-5.0-runtime_5.0-492261_i386.deb
llvm-amdgpu-pro-dev_5.0-492261_amd64.deb
llvm-amdgpu-pro-dev_5.0-492261_i386.deb
llvm-amdgpu-pro-runtime_5.0-492261_amd64.deb
llvm-amdgpu-pro-runtime_5.0-492261_i386.deb
mesa-amdgpu-pro-omx-drivers_17.0.1-492261_amd64.deb
mesa-amdgpu-pro-omx-drivers_17.0.1-492261_i386.deb
opencl-amdgpu-pro-icd_17.40-492261_amd64.deb
opencl-amdgpu-pro-icd_17.40-492261_i386.deb
Packages
Release
rocm-amdgpu-pro_17.40-492261_amd64.deb
rocm-amdgpu-pro-icd_17.40-492261_amd64.deb
rocm-amdgpu-pro-opencl_17.40-492261_amd64.deb
rocm-amdgpu-pro-opencl-dev_17.40-492261_amd64.deb
rocr-amdgpu-pro_1.1.6-492261_amd64.deb
rocr-amdgpu-pro-dev_1.1.6-492261_amd64.deb
roct-amdgpu-pro_1.0.6-492261_amd64.deb
roct-amdgpu-pro-dev_1.0.6-492261_amd64.deb
vulkan-amdgpu-pro_17.40-492261_amd64.deb
vulkan-amdgpu-pro_17.40-492261_i386.deb
xserver-xorg-video-amdgpu-pro_1.3.99-492261_amd64.deb
xserver-xorg-video-amdgpu-pro_1.3.99-492261_i386.deb
xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-492261_amd64.deb
xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-492261_i386.deb
xserver-xorg-video-modesetting-amdgpu-pro_1.19.0-492261_amd64.deb
xserver-xorg-video-modesetting-amdgpu-pro_1.19.0-492261_i386.deb
[email protected]:~/amdgpu-pro-17.40-492261$ sudo chmod +x ./amdgpu-pro-install
[sudo] password for bala: 
[email protected]:~/amdgpu-pro-17.40-492261$ ./amdgpu-pro-install -y
Unsupported OS
[email protected]:~/amdgpu-pro-17.40-492261$

Desconectado

#44 29-08-2018 15:18:43

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

cambia ubuntu por debian en el script con un editor de textos y guarda los cambios.
Captura%20de%20pantalla%20de%202018-08-29%2016-15-51_zpsy0nwengt.png

Desconectado

#45 29-08-2018 15:34:22

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

text editor command???? please roll

Desconectado

#46 31-08-2018 05:19:23

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

Señor, crash..

por favor, creo que estos son los últimos pasos. No sé cómo cambiar el editor de texto para cambiar el sistema operativo, por favor ayuda para mí. Quiero que se instale el controlador AMD para kali. Por favor. dame el comando

Desconectado

#47 31-08-2018 14:43:34

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: Linux tan difícil de instalar AMD GPU

el editor de textos pueden ser muchos, yo uso gedit.

gedit amdgpu-pro-install

debes de cambiar esta línea donde dice ubuntu
Captura%20de%20pantalla%20de%202018-08-29%2016-15-51_zpsy0nwengt.png

por debian para sistema operativo debian
Captura%20de%20pantalla%20de%202018-08-31%2015-33-52_zpscxiauek9.png

edit;
para kali-linux, estado mirando su archivo os-release. y pone lo siguiente: en la iso que tengo yo.
Captura%20de%20pantalla%20de%202018-08-31%2020-34-18_zpszzbsmlqx.png
así que visto el archivo hay que escribir kali
Captura%20de%20pantalla%20de%202018-08-31%2020-53-48_zpsw2290wwp.png
y cuando hayas terminado de editarlo... ctrl+s para salvar los cambios

y ya nos cuentas si da algún otro tipo de error.

Ultima edición por crash (31-08-2018 19:58:50)

Desconectado

#48 31-08-2018 20:27:15

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

yo hago la edición entonces intento instalar amdgpu-pro-install el mismo sistema operativo de soporte de masaje.
por favor tartamudear lo que cometí error.

* un asunto que hice sucssus completo para instalar mi otro HDD Ubuntu 18.04 y Pyrit & RX vega 64 driver amdgpu-pro-18.30-641594 todo bien pero GPU no puede ver *

Desconectado

#49 31-08-2018 20:30:16

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

Desconectado

#50 01-09-2018 14:01:15

bala
Usuario

Registrado: 26-07-2017
Mensajes: 97

Re: Linux tan difícil de instalar AMD GPU

Creo que el controlador GPU & pyrit está bien.
tal vez necesito cambiar
gedit /root/.pyrit/config
use OpenCL = true
pero, ¿qué camino guardo?
Por favor

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

Temas similares

Tema Respuestas Vistas Ultimo mensaje
2 210 Hoy 03:20:43 por manturis
2 150 Ayer 12:11:10 por kcdtv
3 197 Ayer 11:40:47 por kcdtv
Movido:: Ejecutar HashCat en GoogleCloud por alexupps
     
1 138 14-10-2018 21:23:30 por josep345

Pie de página

Información del usuario

Ultimo usuario registrado: ki.llUsser101
Usuarios registrados conectados: 0
Invitados conectados: 12

Estadisticas de los foros

Número total de usuarios registrados: 1,231
Número total de temas: 1,204
Número total de mensajes: 12,409

Máx. usuarios conectados: 69 el 15-10-2017 09:23:21