una vulnerabilidad en wpa_supplicant de mucho interes (Pagina 1) / Seguridad y Hacking / Foro Wifi-libre.com

El libre pensamiento para un internet libre

No estas registrado.     

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#1 29-04-2015 20:53:02

dymusya
Very Important Usuario

Registrado: 19-04-2015
Mensajes: 53

una vulnerabilidad en wpa_supplicant de mucho interes

Hola foreros.
puede ser de mucho interes para los que esten en tema de hacking.

lo hago por primera vez.
Si tiene que estar en otro sitio, por favor admin haga coreciones

  • wpa_supplicant P2P SSID processing vulnerability

  • Published: April 22, 2015

  • Identifier: CVE-2015-1863

  • Latest version available from: http://w1.fi/security/2015-1/

wpa_supplicant-p2p-ssid-overflow.txt escribió:

Vulnerability

A vulnerability was found in how wpa_supplicant uses SSID information
parsed from management frames that create or update P2P peer entries
(e.g., Probe Response frame or number of P2P Public Action frames). SSID
field has valid length range of 0-32 octets. However, it is transmitted
in an element that has a 8-bit length field and potential maximum
payload length of 255 octets. wpa_supplicant was not sufficiently
verifying the payload length on one of the code paths using the SSID
received from a peer device.

This can result in copying arbitrary data from an attacker to a fixed
length buffer of 32 bytes (i.e., a possible overflow of up to 223
bytes). The SSID buffer is within struct p2p_device that is allocated
from heap. The overflow can override couple of variables in the struct,
including a pointer that gets freed. In addition about 150 bytes (the
exact length depending on architecture) can be written beyond the end of
the heap allocation.

This could result in corrupted state in heap, unexpected program
behavior due to corrupted P2P peer device information, denial of service
due to wpa_supplicant process crash, exposure of memory contents during
GO Negotiation, and potentially arbitrary code execution.

Vulnerable versions/configurations

wpa_supplicant v1.0-v2.4 with CONFIG_P2P build option enabled

Attacker (or a system controlled by the attacker) needs to be within
radio range of the vulnerable system to send a suitably constructed
management frame that triggers a P2P peer device information to be
created or updated.

The vulnerability is easiest to exploit while the device has started an
active P2P operation (e.g., has ongoing P2P_FIND or P2P_LISTEN control
interface command in progress). However, it may be possible, though
significantly more difficult, to trigger this even without any active
P2P operation in progress.


Acknowledgments

Thanks to Google security team for reporting this issue and smart
hardware research group of Alibaba security team for discovering it.


Possible mitigation steps

- Merge the following commits to wpa_supplicant and rebuild it:

  P2P: Validate SSID element length before copying it (CVE-2015-1863)

  This patch is available from http://w1.fi/security/2015-1/

- Update to wpa_supplicant v2.5 or newer, once available

- Disable P2P (control interface command "P2P_SET disabled 1" or
  "p2p_disabled=1" in (each, if multiple interfaces used) wpa_supplicant
  configuration file)

- Disable P2P from the build (remove CONFIG_P2P=y)

fuente original : http://w1.fi/security/2015-1/wpa_suppli … erflow.txt

Desconectado

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#2 29-04-2015 21:56:22

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 2,053

Re: una vulnerabilidad en wpa_supplicant de mucho interes

Antes de todo gracias por informarnos
Muy Interesante
El sitio para publicar el tema esta perfecto.
Lo que si es un poco problemático es el copiado pegado del articulo entero
Estas cosas no le gustan a google y deberías poner el texto que no es tuyo como citación.
Te lo arreglo con mi super poderes; no hay problemas. smile
otro detale : un titulo ha de ser un poco descriptivo.
me he permitido retocar el tuyo : con solo hacer aparecer "wpa_suplicant" sabemos ya por dónde van los tiros y permite bien referenciar tu tema en el foro y google para futuras consultas.
Respecto a la brecha nos dicen que concierne todas las versiones anteriores a a la 2.5
lo que significa que la gran mayoría de los dispositivos tanto clientes como puntos de acceso podrían ver se afectados
(ejemplo, con ubuntu15.04 - de este mes - tenemos a wpa_supplicant v2.1)
la ejecución de código arbitrario preciso será difícil de poner de pie y necesitará un buen conocimiento del punto de acceso
lo que parece mas fácil y de interés es para tener un método par DoS y, quien sabe, para hundir el router hasta que se resetean...

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

Temas similares

Tema Respuestas Vistas Ultimo mensaje
Hola! por Ike
1 5 Ayer 23:54:48 por kcdtv
RouterScan linux por juandiegomu
3 29 Ayer 22:06:44 por kcdtv
7 849 Ayer 17:35:28 por kcdtv
1 17 Ayer 11:25:21 por Koala
2 51 Ayer 02:07:10 por kcdtv

Pie de página

Información del usuario

Ultimo usuario registrado: Ike
Usuarios registrados conectados: 0
Invitados conectados: 4

Estadisticas de los foros

Número total de usuarios registrados: 356
Número total de temas: 616
Número total de mensajes: 4,220

Máx. usuarios conectados: 45 el 12-04-2016 12:02:20