[Solucionado] Problemas en archlinux64+Broadcom4313 (Pagina 1) / Wireless y redes en linux. / Foro Wifi-libre.com

El libre pensamiento para un internet libre

No estas registrado.     

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#1 04-10-2015 22:29:44

noxonsoftwares
Usuario

Registrado: 04-10-2015
Mensajes: 2

[Solucionado] Problemas en archlinux64+Broadcom4313

Estimados usuarios del foro. Antes que nada disculpas si mi tema no va en esta seccion. tengo un problema actualmente utilizo archlinux 64 Bit+openbox. Networkmanager y una tarjeta broadcom4313. Utilizando como driver broadcom-wl.

Mi problema es que no logro colocar la interfaz en nodo monitor. Si alguno de ustedes pudo solucionar este problema o tiene conocimientos de algo parecido.

Con kali. Y otras distros ya sea ubuntu, xububtu no tengo este problema.

Gracias por tomarse el tiempo de leer.

---------------------------------------------------------------------------------

Gracias a aquellos que intentaron ayudarme, pues quiero decirles que lo solucione por mi solo de la siguiente manera:

sudo ifconfig wlp1s0b1 down
	sudo iwconfig wlp1s0b1 mode monitor
	sudo ifconfig wlp1s0b1 up

Así de fácil. Saludos

Ultima edición por noxonsoftwares (07-10-2015 04:53:27)

Desconectado

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#2 05-10-2015 11:08:17

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 2,069

Re: [Solucionado] Problemas en archlinux64+Broadcom4313

¡Hola! smile
El tema esta en el foro adecuado. wink
Si te funciona en xubuntu y Kali te va a funcionar en Arch.
¿El chipset funciona correctamente en mode managed?
Dices que "no logras colocar la interfaz en mode monitor"
¿Que obtienes cuando tecleas en consola airmon-ng con derechos da administrador?
(para ver si detecta bien el chipset)
Y luego si podías copiar y pegar lo que ocurre haciendo

airmon-ng start wlan0

  Lo que veo en la wiki de arch es que el driver que usas es peculiar ( Broadcom wireless ) :

bw1.jpg

Dudo que puedas ponerlo en mode monitor: es un driver de fabricante.

Leyendo un poco más he encontrado esto : Broadcom BCM4313 MONITOR MODE

IMPORTANT

Some chips are covered by both the “b43” and “wl” driver. If you have such device, you have to make sure you blacklist the “wl” driver before you utilize b43, otherwise they will collide and your card will stop functioning altogether, let alone hope for injection. The “wl” driver does not support aircrack-ng.

Lo que confirmaría lo que supongo ; el driver "wl" no permite el mode monitor.
Deberías poner lo en la blacklist para tirar del "genérico" que soporta el mode monitor.
  Si tienes la oportunidad de pasar en mode monitor en kali o xubtunu; fijate bien en el driver empleado (lo ves en consola cuando usas airmon-ng).
¡Hasta pronto y bienvenid@ a wifi-libre! wink

Desconectado

#3 06-10-2015 16:29:20

noxonsoftwares
Usuario

Registrado: 04-10-2015
Mensajes: 2

Re: [Solucionado] Problemas en archlinux64+Broadcom4313

Gracias por la respuesta, pues bien como pides esto es airmon-ng

┌─( noxonsoftwares ) » [ ~ ]
└──┤ sudo airmon-ng
PHY	Interface	Driver		Chipset

phy0	wlp1s0b1	brcmsmac	Broadcom on bcma bus, information limited

esto es intentando colocar mi tarjeta en modo monitor

┌─( noxonsoftwares ) » [ ~ ]
└──┤ sudo airmon-ng start wlp1s0b1
Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

  PID Name
  397 NetworkManager
  404 avahi-daemon
  408 avahi-daemon
  514 wpa_supplicant
 2501 dhclient

PHY	Interface	Driver		Chipset

phy0	wlp1s0b1	brcmsmac	Broadcom on bcma bus, information limitedcommand failed: Device or resource busy (-16)

		(mac80211 monitor mode vif enabled for [phy0]wlp1s0b1 on [phy0]wlp1s0b1mon)
		(mac80211 station mode vif disabled for [phy0]wlp1s0b1)

Ese es el problema que tengo, la verdad que no se como solucionarlo. Ya hace tiempo vengo intentando.

Desconectado

#4 07-10-2015 15:27:04

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 2,069

Re: [Solucionado] Problemas en archlinux64+Broadcom4313

¡Que bueno! : Solo traes buenas noticias. smile

  1. ¡Parece que el driver esta funcionando correctamente y que permite el mode monitor! cool
    Tienes una interfaz "física" - phy0 - vinculada correctamente a tu interfaz disponible para el sistema - wlp1s0b1 - y además cuando activas el mode monitor lo hace correctamente y obtienes wlp1s0b1mon. ¡Vamos bien! wink

  2. Tenemos la solución para el problema

    information limitedcommand failed: Device or resource busy (-16)

    . Hemos hablado de este problema aquí :     Kali 2.0 evitar que networkmanager nos *robe las interfaces en monitor. Y aquí hablamos de la solución la más conveniente : Modificación del fichero NetworkManager.conf para arreglar airmon-ng

  En resumen : las versiones de Network manager sacadas después marso 2015  impiden que puedas utilizar la interfaz en mode monitor. Es un problema que encontramos en todas distribuciones y que podemos arreglar así:

sudo echo "
[keyfile]
unmanaged-devices=interface-name:wlp1s0b1mon;                   # añadido octubre 2015 para resolver conflictos con airmon-ng "  >> /etc/NetworkManager/NetworkManager.conf

  Así vas a añadir estas dos lineas al fichero de configuración de Network Manager para que deje en paz tu interfaz wlp1s0b1mon que podrás usar en mode monitor. smile

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

Pie de página

Información del usuario

Ultimo usuario registrado: evam
Usuarios registrados conectados: 0
Invitados conectados: 3

Estadisticas de los foros

Número total de usuarios registrados: 357
Número total de temas: 621
Número total de mensajes: 4,272

Máx. usuarios conectados: 45 el 12-04-2016 12:02:20