El libre pensamiento para un internet libre

No estas registrado.  

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#1 02-09-2017 15:14:21

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

fallo al instalar la AWUS1900 por asunto de kernel

Hola,

Buscando por la red, informacion sobre una nueva antena wifi, me encontre con este foro. Me gusto el post de la AWUS1900 y su rendimiento, decidi comprarla. La probe en windows sin problemas. Pero para poder hacer auditorias decidi instarlar kali linux. La primera vez lo instale junto a mi W10. Descargo la ISO y la instalo en un USB, hago la instalacion y compruebo con uname -r que mi Kernel se encuentra en la version 4.9.0 Kali3. Como he leido en el post se soluciona, actulizando el kernel a la version mas nueva, en este caso 4.9.0 Kali4.

Para ello, edito el archivo /etc/apt/source.list

edito las lineas de los repositorios de Kali rolling, desmarcando las almohadillas.

tecleo:

sudo apt update && sudo apt upgrade && sudo apt dist-upgrade && sudo systemctl reboot

Y ahora viene el  problema, se inicia o se actualiza a la version del kernel 4.12. Seleciono entonces en mas opciones en el grub y busco el kernel 4.9.0 kali3

No me deja actulizarlo a la version 4.9.0 Kali4 o la 4.12 o la 4.9.0 kali 3

Alguna sugerencia que puedo estar haciendo mal??

He investigado por internet como actualizarlo de muchas formas, pero ninguna consigo que me muestre Kali4

Gracias.

PD: Buen foro, con informacion valiosa

Ultima edición por mind777 (02-09-2017 18:20:27)

Desconectado

Anuncio

Wifi-highpower.es es distribuidor oficial de Alfa Network

#2 02-09-2017 16:45:51

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

Bienvenido al foro .

edito las lineas de los repositorios de Kali rolling, desmarcando las almohadillas.

No es lo que debes hacer: Editar la lista de repositorios para poder instalar cualquier programa

Las liñas a añadir al fichero sources.list son ahora estas :

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free

- Si hemos instalado Kali Linux 2016.1 con la imagen ISO "normal"  nuestro fichero quedará así:

sudo leafpad /etc/apt/sources.list

editar_lista_repositorios.jpg

En la captura de pantalla podeís ver que he decidido quitar la almohadilla (uncomment - "descomentar" )  en la tercera y ultima linea del trozo de texto que se debe añadir.
  No es necesario.
Me dará acceso a los paquetes fuentes de los paquetes *.deb disponibles desde los repositorios "rolling"
No me permite acceder a más aplicaciones o librerías.

Desconectado

#3 02-09-2017 18:20:16

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Gracias por la respuesta, lo he vuielto a instalar de nuevo un Kali Linux 2017.1. Despues de la instalacion he editado el archivo sourcelist con las linesas quue me has señalado.

sudo apt update && sudo apt upgrade && sudo apt dist-upgrade && sudo systemctl reboot

Pruebo de nuevo:

make RTL8814=1
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.0-kali1-amd64/build M=/root/rtl8812au  modules
make[1]: *** /lib/modules/4.12.0-kali1-amd64/build: No existe el fichero o el directorio.  Alto.
Makefile:1855: fallo en las instrucciones para el objetivo 'modules'
make: *** [modules] Error 2

Se ha actualizado a la :

[email protected]:~/rtl8812au# uname -a
Linux Mind 4.12.0-kali1-amd64 #1 SMP Debian 4.12.6-1kali6 (2017-08-30) x86_64 GNU/Linux

Lo he intenado de esta forma:

apt install realtek-rtl88xxau-dkms 

8814au.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.12.0-kali1-amd64/updates/

depmod...

DKMS: install completed.
Configurando linux-headers-4.12.0-kali1-amd64 (4.12.6-1kali6) ...
Configurando linux-headers-amd64 (4.12+84+kali1) ...

Creo que se ha instalado, he intento activar el driver:

[email protected]:~/rtl8812au# modprobe rtl8814au
modprobe: FATAL: Module rtl8814au not found in directory /lib/modules/4.12.0-kali1-amd64

Pero me dice esto, alguna idea ?

Gracias de nuevo.

Hola he conseguido instalarla, y que reconozca el dispositivo Wifi, pero cuando le cambio el chipset con :

modprobe rtl8814au
modprobe: FATAL: Module rtl8814au not found in directory /lib/modules/4.12.0-kali1-amd64

me da error

Alguna idea ??

Gracias de nuevo.

Desconectado

#4 02-09-2017 18:54:13

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

He editado tu mensaje con la opción "insertar código.", si la próxima vez lo haces así, xaxi.  wink
Bueno, supongo que el modulo dkms no está actualizado para kernel 4.12
Lo más simple es que instales la versión de los drivers desde el github de aircrack-ng que va bien con el ultimo kernel:
RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection (desde aircrack-ng)
Ojo con una cosa: si instalas la awuso36ach debes instalar el driver 8812au (no hagas un make especificando "8814au", haces make y punto)

Desconectado

#5 02-09-2017 19:27:45

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Queda mucho mas claro para leer, gracias smile

He desistalado la otra version de astsam, que no soporta 4.12 kernel, por la que me dices:

apt autoremove realtek-rtl88xxau-dkms 

Luego he hecho git clone a los drivers de aircrack-ng, que si soportan esta version:

[email protected]:/home/Documentos# git clone https://github.com/aircrack-ng/rtl8812au.git

Mi tarjeta es la AWUS1900, asi que ejecuto :

make RTL8814=1

Lo compila, pero al final me sale esto:

  CC      /home/Documentos/rtl8812au/8812au.mod.o
  LD [M]  /home/Documentos/rtl8812au/8812au.ko
make[1]: se sale del directorio '/usr/src/linux-headers-4.12.0-kali1-amd64'

Luego seria:

make install

Alguna idea ?

Gracias

Desconectado

#6 03-09-2017 14:02:08

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

Mi tarjeta es la AWUS1900

Es que es un detalle que tiene su importancia smile
Bueno... Lo más simple es primero... "descompilar"
Haces

make clean

En el directorio rtl8812au, el mismo sitio que cuando has compilado
Luego abres el fichero makefile para editarlo:

awus1900_compile_1.jpg

Tu linea para 8814au debe quedar así:

CONFIG_RTL8814A = y

Y luego haces simplemente

make 
sudo make install

Y lo tendrás instalado.
Se recomienda el uso de la rama 4.3.21 para este dispositivo.
saludos smile

Desconectado

#7 03-09-2017 18:40:56

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Hola,

he intentado de nuevo instalarlo, esta vez la version 4.3.21, primero decompilando;

[email protected]:~/Documentos/rtl8812au# make clean
#make -C /lib/modules/4.12.0-kali1-amd64/build M=/root/Documentos/rtl8812au clean

Segundo edito el archivo Makefile:

########################## WIFI IC ############################
CONFIG_MULTIDRV = n
CONFIG_RTL8188E = n
CONFIG_RTL8812A = n
CONFIG_RTL8821A = n
CONFIG_RTL8192E = n
CONFIG_RTL8723B = n
CONFIG_RTL8814A = y
CONFIG_RTL8723C = n

Guardo los cambios, y ejecuto make:

[email protected]:~/Documentos/rtl8812au# make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.0-kali1-amd64/build M=/root/Documentos/rtl8812au modules
make[1]: se entra en el directorio '/usr/src/linux-headers-4.12.0-kali1-amd64'
  LD [M]  /root/Documentos/rtl8812au/8814au.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /root/Documentos/rtl8812au/8814au.mod.o
  LD [M]  /root/Documentos/rtl8812au/8814au.ko
make[1]: se sale del directorio '/usr/src/linux-headers-4.12.0-kali1-amd64'

Termino con make install:

[email protected]:~/Documentos/rtl8812au# make install
install -p -m 644 8814au.ko  /lib/modules/4.12.0-kali1-amd64/kernel/drivers/net/wireless/
/sbin/depmod -a 4.12.0-kali1-amd64

He intento levantarl el adaptador wifi con:

[email protected]:~/Documentos/rtl8812au# modprobe rtl8814au
modprobe: FATAL: Module rtl8814au not found in directory /lib/modules/4.12.0-kali1-amd64

Pero no lo consigo. Alguna idea ?

Gracias de nuevo por su ayuda smile

Ultima edición por mind777 (03-09-2017 18:52:36)

Desconectado

#8 03-09-2017 18:53:20

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

Mejor así wink

modprobe 8814au

Y de paso un consejo amistoso : Haz te una cuenta de usuario, sobre todo si experimentas con drivers y estas conectado a la red.
Un sistema gnu-linux se usa desde une cuenta de usuario a diario.
Si quieres tener derechos de administrador usa sudo... para esto está. smile

Desconectado

#9 03-09-2017 18:57:29

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Ahora si

Muchisimas gracias

big_smile

Ahora mismo, creo mi usuario sin privilegios.

Un placer

Gran foro - WIFI LIBRE

Ultima edición por mind777 (03-09-2017 18:58:45)

Desconectado

#10 03-09-2017 19:04:29

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

De nada smile
  Supongo que los de kali van a hacer algo un día para arreglar su paquete dkms... tongue
Tenía entendido que los módulos dkms estaban justamente para evitar este tipo de incompatibilidades.

Desconectado

#11 03-09-2017 19:19:44

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Bueno probando un poco, consigo conectarme sin problemas a mi wifi 5g pero no consigo conectarme a la bande de 2.4 gh.

¿ Por qué una si y la otra no ?

La contraseña es correcta.

Que puede pasar ??

Las actulaizaciones no van en conjunto, se iran resolviendo a medida que se actualicen el resto

Si buscas, lo consigues tongue

Ultima edición por mind777 (03-09-2017 19:21:20)

Desconectado

#12 03-09-2017 21:45:44

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

consigo conectarme sin problemas a mi wifi 5g pero no consigo conectarme a la bande de 2.4 gh.

Es extraño, a mi nunca me ha pasado.
A priori no es cosa del adaptador.
Prueba conectarte a la red 2.4Ghz redactando  "a mano" las direcciones ipv4.
Si haces

sudo dmesg 

verás en la ultimas lineas la razón del falló de la conexión.

Desconectado

#13 05-09-2017 15:35:03

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Lo solucione simplemente reinciando Linux, y ya funciona todo correctamente. Tambien he probado a snifar e inyectar paquetes sin problemas. He usado La naraja mekanika, y perfecto. He podido averiguar mi PIN. Tuve que aprender tambien como configurar wpa client para que se asocie con el router y le envie la clave WPA. Estoy muy contento.

Seguire leyendo por el foro, para aprender mas.

Sobre el comando iwconfig wlanx txpower 30

cambia la potencia pero no lo muestra con el comando iwconfig, creo haber entendido. Esta harcodeado esa cifra ??

Gracias

Desconectado

#14 05-09-2017 16:24:59

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

Lo solucione simplemente reinciando Linux, y ya funciona todo correctamente. Tambien he probado a snifar e inyectar paquetes sin problemas. He usado La naraja mekanika, y perfecto. He podido averiguar mi PIN. Tuve que aprender tambien como configurar wpa client para que se asocie con el router y le envie la clave WPA.

¡Olé! Has sido productivo estos días. smile

cambia la potencia pero no lo muestra con el comando iwconfig, creo haber entendido. Esta harcodeado esa cifra ??

"hardcoded" o "softcoded"... En todos casos es un valor fijo y inútil porqué sin relación con la realidad
El control de potencia solo está implementado en la rama v4.3.21
No he conseguido instalar está rama... Es una lastima porqué iba a mi gusto un poco mejor con la AWUS1900.
Con el kernel 4.12 tengo a "advertencias severas consideradas como errores" y tengo que usar el kernel 4.9 para poder usar esta rama. hmm

Desconectado

#15 29-12-2017 04:27:42

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Hola de nuevo,

he estado un tiempo si usar Linux, y a la vuelta estoy teniendo problemas con el adaptador wifi, lo deje con la configuracion anterior que me funcionaba sin problemas, pero ahora no se conecta a las redes, si me aparecen, pongo la contraseña pero no se conecta, alguna vez os a pasado algo parecido. He vuelto a instalar de nuevo el driver pero sin resultado.

Alguna idea de cual puede ser el error.


Gracias, y Felices Fiestas

Un saludo a todos.

Ultima edición por mind777 (29-12-2017 05:03:25)

Desconectado

#16 29-12-2017 16:15:16

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

alguna vez os a pasado algo parecido.

No.
Qué tienes en final de dmesg?

Desconectado

#17 30-12-2017 15:07:59

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

mind777 escribió:

Gracias por la ayuda

Pongo aquí lo que me muestra el comando "dmesg" respecto al adaptador WIFI:

[3.314645] usb 4-5: new SuperSpeed USB device number 3 using xhci_hcd
[    3.334843] usb 4-5: Int endpoint with wBytesPerInterval of 512 in config 1 interface 0 altsetting 0 ep 133: setting to 64
[    3.334992] usb 4-5: New USB device found, idVendor=0bda, idProduct=8813
[    3.334993] usb 4-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.334993] usb 4-5: Product: 802.11ac NIC
[    3.334994] usb 4-5: Manufacturer: Realtek
[    3.334994] usb 4-5: SerialNumber: 123456
[    3.458606] usb 3-10: new high-speed USB device number 6 using xhci_hcd
[    3.471347] usbcore: registered new interface driver 8814au
[    3.474169] 8814au 4-5:1.0 wlx00c0ca95866f: renamed from wlan0
[    3.538158] IPv6: ADDRCONF(NETDEV_UP): wlx00c0ca95866f: link is not ready

Gracias por la ayuda

crash escribió:

borra en esta ruta el archivo de red que te sale con el nombre tuyo de tu red
/etc/NetworkManager/system-connections/
vuelve a conectarte y te volverá a pedir la clave. introducela y nos cuentas qué te hace.

mind777 escribió:

Me sigue pidiendo la clave de nuevo, no se conecta.

Primero vamos a hacer las cosas bien es decir parra de piratear el tema sobre awus036ach para hablar de la awus1900 big_smile
Luego deberías bien actualizar tu sistema, kali se tiene que actualizar a menudo, es roling release.
Actualiza el kernel (dist-upgrade) etc... reinstala los drivers y mira que pasa. Si no lo consigues intenta primero conectarte con wpa_suplicant (hay tutoriales en el foro) para ver si no es antes de todo un  problema de networrk manager.

Desconectado

#18 31-12-2017 14:49:25

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Gracias, empecemos con actualizar el kernel  del sistema:

[email protected]:/home/mind# apt dist-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Calculando la actualización... Hecho
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
[email protected]:/home/mind# 

Compruebo que tambien este actualizado NetworkManager:

apt-get install network-manager
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
network-manager ya está en su versión más reciente (1.6.2-3).
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
[email protected]:/home/mind# 

Pruebo a conectarme a traves de Wpa_supplicant:

wpa_supplicant -B -Dnl80211,wext -iwlx00c0ca95866f -c /etc/wpa_supplicant.conf 
Successfully initialized wpa_supplicant
[email protected]:/home/mind# dhclient wlx00c0ca95866f

Sigue sin conectarse.

Creo que tengo algo mal configurado en el archivo /etc/network/interfaces :

Ademas me sale eno1, yo no recuerdo cambiarle el nombre al adaptador.
Y sobre el adaptador Wifi me sale otro nombre extraño, pero funcional "wlx00c0ca95866f" :

[email protected]:/home/mind# ifconfig
eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.44  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::7a24:afff:febd:3495  prefixlen 64  scopeid 0x20<link>
        ether 78:24:af:bd:34:95  txqueuelen 1000  (Ethernet)
        RX packets 41671  bytes 37619055 (35.8 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 31566  bytes 4399653 (4.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf7200000-f7220000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 4244  bytes 359109 (350.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4244  bytes 359109 (350.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vmnet1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.29.1  netmask 255.255.255.0  broadcast 192.168.29.255
        inet6 fe80::250:56ff:fec0:1  prefixlen 64  scopeid 0x20<link>
        ether 00:50:56:c0:00:01  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 230  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vmnet8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.27.1  netmask 255.255.255.0  broadcast 192.168.27.255
        inet6 fe80::250:56ff:fec0:8  prefixlen 64  scopeid 0x20<link>
        ether 00:50:56:c0:00:08  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 231  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlx00c0ca95866f: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 96:a1:37:41:c1:64  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[email protected]:/home/mind# iwconfig
wlx00c0ca95866f  IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=18 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
vboxnet0  no wireless extensions.

vmnet1    no wireless extensions.

vmnet8    no wireless extensions.

lo        no wireless extensions.

eno1      no wireless extensions.

[email protected]:/home/mind# 

Sigo sin saber cual es el problema, no se me ocurre que puede ser.

[email protected]:/etc/network/interfaces.d# cd /etc/udev/rules.d/
[email protected]:/etc/udev/rules.d# ls
60-vboxdrv.rules

Creo que me faltan archivos, en este directorio.

Ultima edición por mind777 (31-12-2017 14:52:08)

Desconectado

#19 31-12-2017 15:14:11

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Bueno probando cosas, creo que añadir los archivos que me faltaban:

Ha podido conectarse:

[email protected]:/etc/udev/rules.d# ls
60-vboxdrv.rules	73-special-net-names.rules
70-persistent-cd.rules	73-usb-net-by-mac.rules

Iwconfig :

[email protected]:/etc/udev/rules.d# iwconfig
vmnet1    no wireless extensions.

vmnet8    no wireless extensions.

eno1      no wireless extensions.

wlp0s20u5  IEEE 802.11  ESSID:"MOVISTAR_PLUS_FF3A"  
          Mode:Managed  Frequency:5.54 GHz  Access Point: 34:57:60:D5:FF:43   
          Bit Rate=450 Mb/s   Tx-Power=18 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=40/70  Signal level=-70 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

[email protected]:/etc/udev/rules.d# 

Ahora quiero cambiar el nombre de las interfaces, por : Eth0 y Wlan0


Gracias por acompañarme en la configuración y los consejos.

Feliz 2018 cool

Desconectado

#20 31-12-2017 17:22:52

crash
Expulsado

Registrado: 25-10-2017
Mensajes: 1,049

Re: fallo al instalar la AWUS1900 por asunto de kernel

editar este archivo con gedit u otro /etc/default/grub

viene vacio.

GRUB_CMDLINE_LINUX=""

añade esto guarda cambios y reinicia y ya tendras eth0 y wlan0

GRUB_CMDLINE_LINUX="net.ifnames=0"

Desconectado

#21 31-12-2017 19:41:36

d1k0w0ns
Expulsado

Registrado: 12-06-2015
Mensajes: 374

Re: fallo al instalar la AWUS1900 por asunto de kernel

vaya follon para instalarla no?

en el supuesto sponsor Wifi-highpower.es no tienen esta targeta esta dificil comprar una solo la venden en murcia o en china
habia pensado hacerme un auto myself reyes magos for me xD

Desconectado

#22 31-12-2017 20:52:34

mind777
Usuario

Registrado: 02-09-2017
Mensajes: 16

Re: fallo al instalar la AWUS1900 por asunto de kernel

Nada, es un follon al principio que aprendes, ya lo tengo listo y funcionando como siempre.

Pillatela para Reyes es una muy buena herramienta.

Sobre modificar el archivo /etc/default/grub la linea

GRUB_CMDLINE_LINUX=" "

Por :

 GRUB_CMDLINE_LINUX="net.ifnames=0"

No me ha dado resultado, investigare mas, habrá mas formas.

Ultima edición por mind777 (31-12-2017 20:52:55)

Desconectado

#23 01-01-2018 18:39:47

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

Personalmente he dejado de usar el paquete dkms. Total: Se debe reinstalar una vez sobre dos cuando se cambia de kernel.
Prefiero tener los módulos preparados para cada rama.
Con los repositorios rtl812au de aircrack-ng la cosa fluye bastante: Siguen muy de cerca la actualidad del kernel, tenían el soporte 4.15 listo antes de que saliera el kernel estable. Trabajan con las versiones de desarrollo y mantienen un muy buen ritmo.
@ Mindu
Es raro que tengas wlxXXXXXXXX en Kali ya que por defecto sobrescriben las reglas sytem.d para revertir la nueva "naming policy"
Deberías tener el antiguo esquema: ethX para las interfaces cable, wlanX para las interfaces wifi.

Desconectado

#24 17-01-2018 13:13:40

d1k0w0ns
Expulsado

Registrado: 12-06-2015
Mensajes: 374

Re: fallo al instalar la AWUS1900 por asunto de kernel

kcdtv donde te compraste la tuya??
en la tienda del sponsor del foro no la tienen

Desconectado

#25 18-01-2018 10:05:06

kcdtv
Administrator

Registrado: 14-11-2014
Mensajes: 4,529

Re: fallo al instalar la AWUS1900 por asunto de kernel

No uses el hilo que te sale de las narices para hacer tus preguntas, ¿Qué tiene que ver tu pregunta con el tema de este hilo?  roll
No he comprado la tarjeta, me la han mandado wifi-high power, lo explico en inicio de la review.  No sé de tiendas o sitios para hacer tus compras.

Desconectado

Anuncio

Wifi-libre.com: El libre pensamiento para un internet libre / Regístrese ahora

Temas similares

Tema Respuestas Vistas Ultimo mensaje
4 229 Ayer 20:21:00 por Betis-Jesus
0 88 13-11-2018 16:13:33 por kcdtv
0 84 12-11-2018 18:16:07 por kcdtv
35 26308 12-11-2018 15:36:56 por kcdtv
Hola a todos por fractalia
7 200 12-11-2018 14:32:06 por fractalia

Pie de página

Información del usuario

Ultimo usuario registrado: KiViEr
Usuarios registrados conectados: 0
Invitados conectados: 8

Estadisticas de los foros

Número total de usuarios registrados: 1,274
Número total de temas: 1,224
Número total de mensajes: 12,538

Máx. usuarios conectados: 74 el 13-11-2018 18:47:20